Des trucs et des astuces

Alors amusons -nous ;)

27 avril 2007

J'ai mis du code HTML dans "Liens d'amis"

...et maintenant, ça n'affiche plus rien....

Au début, on a un code à insérer dans son blog, pour un compteur, une horloge, un post-it et/ou un éphéméride...

Et bien, sûr , comme on le veut sur une colonne pourquoi pas les "liens d'amis" bonne idée ça!!!!


oui oui oui, et zou c'est parti sauf qu'une fois qu'on a appuyé, le résultat n'est pas celui escompté, plus rien, un vide...

même plus les autres liens,

Rhaaaaaaa $£¤*ù%%, Diaule!!! mais qu'ai-je fait!!!!! (aparté pour ceux qui l'ont déjà fait dans les catégories - zêtes tétus vous....)

Bon.... on fait comment maintenant? Il faut corriger, supprimer la source du bug. (j'ai comme l'impression de me répéter moi).


Dans un premier temps il faut cliquer-droit dans cette fenêtre de "Gestion des liens" et sélectionner "Afficher la source"

Le code Html de la page va se retrouver dans le bloc-notes.

(Nota: Avec un navigateur FF, il faut tout sélectionner, le copier et recoller le code dans le bloc note pour pouvoir modifier et sauvegarder correctemement)
(attention très important, restez connecté sur votre interface canalblog pendant toutes les opérations)

et dans ce fichier source on va juste "bidouiller" un peu de code, en prenant toutes les précautions d'usage, d'accord?

déjà juste pour comprendre, il faut savoir que les liens et le dernier ajouté font partie du code html de la page, mais, comme ce dernier lien est du code incomplet, l'explorateur ne peut l'interpréter, et n'affiche plus rien après.

donc nous nous trouvons avec un fichier (ici my[2]), il faut repérer les lignes où sont inscrits les liens... vous reconnaîtrez facilement le votre.


on repère facilement les <a href="....>là se situe en général le nom du lien mais dans lequel figure maintenant le <script...> </td>
06lelien
on sélectionne tout ce qui est entre les balise <a href="..."> </a></td> et on y met "A supprimer" (bon c'est simplement pour bien définir celui qui est à effacer)

Ensuite on va encore modifier autre chose, en dessous de ce titre, il y a une ligne marquée :"<a href="/cf/my/action/FriendLinkController.cfc?bid...." cette ligne sert à supprimer le lien (3 ème ligne en dessous de celle qu'on a déjà modifiée)
il faut rajouter l'adresse de Canalblog juste avant "/cf/my/action...."

Voilà nous y sommes presque, ce fichier on va le sauvegarder sur notre disque, avec l'extension ".html": important, car ça va nous permettre de le lancer avec l'explorateur. (Démarrer - mes document - my[2].html)

Donc on le lance, la page va s'afficher il n'y aura pas de décoration, ni de mise en page, mais peu importe, le tableau avec les liens apparaît , dont le "a supprimer" (faute d'orthographe incluse)

et on va appuyer sur le carré à droite de "Editer" qui permet de l'effacer (un carré car pas d'image chargée), avec notre modif, la seule chose que vous pourrez effectuer est la suppression, tout le reste ne fonctionnera pas. donc go sur le bouton à droite de Editer

si tout va bien, vous devriez revenir sur un tableau avec toute la liste de vos liens

(et bon je le répète: ce n'est pas une raison, non plus, pour y remettre du code, ok?)


Commentaires

    bonjour Alèrion
    j'ai planté mon blog en voulant mettre un compteur malgré tous vos avertissements,depuis plus de 3 heures j'essaie de répare mais je n'y arrive pas,je suis nul en informatique ,c'est pourquoi que je vous demande de l'aide car je crois que je fais plus de mal qu'autre chose mon blog est laurentine49
    c'est un blog de layette je ne sais plus quoi faire
    merci pour vos explications mais je suis trop nul

    Posté par laurentine49, 24 octobre 2007 à 17:07
  • [dingding] ça remarche je crois que j'ai réussis merci [Bouquet]pour les explications[Ange]

    Posté par laurentine49, 24 octobre 2007 à 17:16
  • [Clin d oeil] de rien :)

    Posté par Alérion, 24 octobre 2007 à 19:55
  • trop nulle

    merci pour ton aide...j'ai suivi à la lettre tes explications...sauf que horreur, c'est pas un lien qu'il fallait supprimer mais au moins une 20taine (bah vi, quand le compteur y s'affiche pas, faut bien réassayer et réassayer encore et encore....) - bref quand je suis sur mon [my2] bque jer l'ouvre, apparaisent bien tous les à supprimer...+ carré à côté de éditer...et quand je clique dessus - cela ne fait rien ou pire "erreur de connexion...
    que dois-je faire?
    http://polymers.canalblog.com

    Posté par poulpinette, 25 octobre 2007 à 12:10
  • CA Y EST OUF!

    un enorme MERCI[Héééhooo][Danser][Danser][Danser][copain][Bouquet]
    J'ai réassayé, pas à pas, lien après lien, et j'ai réussi...ce qui merdait c'était : http://WWW.canalblog.com - bah vi fallait que je mette le WWW...
    mais maintenant j'ai tout enlvé ce qui n'allait pas!!! grand merci pour ce tuto - bisous!

    Posté par poulpinette, 25 octobre 2007 à 15:29
  • Code inséré dans le titre

    Salut alerion
    En consultant ton blog je vois que plusieurs on fait la même bêtise que moi : mettre du code htm dans le titre. Je vois que tu as su les dépanner mais sans donner la manip sur le blog. Peux-tu, m'indiquer comment faire pour avoir de nouveau accès à mon blog. La page paramètres (où se trouve le titre est inaccessible).
    Merci d'avance.

    Posté par fraubert, 25 octobre 2007 à 16:56
  • oui, c'est comme virer le chauffeur alors qu'on a pas le permis... mais je te répondrai que ce que j'ai répondu sur le forum c'est très dificile :( ça se fait uniquement en ligne et FireFox avec firebug -pas possible autrement et c'est d'autant plus délicat que c'est sur cette page qu'on peut aussi supprimer (sans retour possible) le blog, donc pas le droit à l'erreur, donc je n'ai pas fait de tuto dessus, voilà.
    maintenant je te maile.

    Posté par Alérion, 25 octobre 2007 à 19:37
  • Besoin d'aide !!!!

    Comme d'autres, j'ai fait une méga erreur en voulant insérer une horloge ! Je suis allée voir ce que tu préconises pour réparer les dégâts mais contrairement à ce que tu expliques, je ne trouve pas le lien à supprimer dans le bloc-notes. Pourtant je lis patiemment toutes tes instructions ! Juré ! STP Alérion, je suis en pleine panique ! Faut m'aider ! Ma famille et mes amis qui vivent à 20000 kms de moi attendent des news sur mon blog et je ne peux leur donner ! Dans tout ce bordel là-dessous je ne retrouve pas le lien de l'horloge !!! Mais y'a trop de choses dans ce bloc-notes pour que je puisse tout t'envoyer.....Suis vraiment désolée de t'ennuyer mais vraiment il faut trouver une solution ! Merci bcp bcp bcp d'avance. Margot

    Messages

    Commentaires

    Rétroliens

    Liens d'amis

    Catégories

    Albums photos

    Posté par Margot, 10 novembre 2007 à 23:06
  • merci

    Merci, Merci Merci Merci[Bouquet][Bouquet][Bouquet][Bouquet]me voici sauvée grace a ton tuto[Héééhooo][Bravo]t'es un [Ange](cool les smileys)

    Posté par Babeth, 12 novembre 2007 à 14:35
  • Fausse Manip'...

    Bonjour à toi !

    Je viens de réaliser une prouesse : insérer par mégarde du code HTML en lieu et place du titre de mon blog.
    Et une catastrophe n'arrivant jamais seule avec moi, j'ai ete déconnectée de l'interface Canalblog dans la foulée, suite à une coupure de courant chez moi...
    Mon cas te semble-t-il désespéré...???
    Inutile de préciser que je tenais à ce blog !!!

    Merci d'avance si tu as une solution à me proposer !

    Lilly

    .

    Posté par Lilly, 01 mai 2007 à 17:00
  • je t'ai envoyé un mail Lilly :)[Coder]

    Posté par Alérion, 02 mai 2007 à 19:08
  • MERCI A Perséphone

    de m'avoir dirigé sur ton blog
    LONGUE VIE A TOI

    surtout que cela marche aussi sur les albums photos

    MERCI

    Posté par erwi, 11 juin 2007 à 21:38
  • et un hiphiphip hourrahhh pour Persé [Héééhooo][Danser][Bouquet]

    Posté par Alérion, 11 juin 2007 à 22:25
  • moi c'est pas pareil, m'sieur

    bonjour, j'ai un souci est-ce que vous pouvez me dépanner?
    j'ai mis une horloge dans le titre, à la place de la bannière, je suis en mode normal.
    et j'ai beau lire, je ne trouve pas comment faire, car je n'ai qu'un carré gris dès le début dans la gestion des blogs.
    si vous pouvez voir http://nonoemie.canalblog.com comment je peux la retirer[mmm]

    Posté par Nono, 09 juillet 2007 à 14:15
  • Arf, nono, là ce n'est pas facile surtout dans le titre du blogg, bon je t'ai mailé, on va voir ce qu'on peut faire[Attend]

    Posté par Alérion, 12 juillet 2007 à 20:59
  • [Victoire]alors là je te suis reconnaissante jusqu'a la fin de ma vie,
    trop trop contente, merci merci merci[Youpiii][YoupYoup][Bravo][Bouquet] t mon dieu[bon ok]

    Posté par Nonoe, 13 juillet 2007 à 13:00
  • [Clin d oeil]de rien

    Posté par Alérion, 13 juillet 2007 à 21:55
  • salut Alérion

    ça fait longtemps que je ne t'ai pas dérangé,

    stp, j'ai vu des blogs quand ils présentent leurs messages il y a une case en bas de la recette par exemple (puisque j'entre dans les blogs de cuisine), la case dit : imprimer cet article

    svp, je veux savoir comment faire

    Posté par oum rayane, 15 juillet 2007 à 17:04
  • autre chose

    je t'invite à voir ce blog
    http://petitelolie.canalblog.com/
    je veux savoir comment la propriétaire du blog a mis en valeur les titres des catégories c'est à dire comment elle a ecris sur des cases et les a mis dans une colonne

    Posté par oum rayane, 15 juillet 2007 à 17:10
  • bonsoir oum, je pense que tu trouveras ton bonheur chez notre démolite : http://demolitetuto.canalblog.com/ il y a une fouletitude de chose [Clin d oeil][Youpiii]

    Posté par Alérion, 16 juillet 2007 à 19:30
  • Extension htlm

    On clique sur quoi pour avoir l'extension htlm ?.

    Posté par Lionel, 20 juillet 2007 à 16:20
  • en changeant l'extension .txt par .html [Oui]

    Posté par Alérion, 21 juillet 2007 à 06:34
  • Code htlm

    Malgré tes explications,je n'arrive pas à enlever le code htlm du logo que j'ai mis sur mon blog.Je n'y connais pas grand chose en informatique.Si je te donne mon identifiant et mon mot de passe,serais-tu d'accord pour me dépanner ?.Si c'est oui,envoie-moi un E-mail et je te donnerai ce qu'il faut.Merci de me répondre.

    Posté par Lionel, 21 juillet 2007 à 12:38
  • tu l'as mis où ce code? liens d'amis ou catégories?[mmm]
    sinon je te t'ai mailé

    Posté par Alérion, 21 juillet 2007 à 14:00
  • j'y arrive pas

    bonjour Alérion
    j'ai bein évidemment fait cette bétise et maintenant il faut réparer mais dès la premire étape j'y arrive.
    C'est à dire que je ne retoruve pas le nom du lien dans le :my(1) bloc-notes [mmm]
    j'ai inséré le code dans mes liens d'amis : dans : ajouter une nouvelle catégorie à ce lien
    peux tu m'aider, on ne voir plus rien sur mon blog????
    je ne suis pas une pro du langage informatique ;-)
    merci d'avance

    Posté par nuage de lait, 02 août 2007 à 14:13
  • oui, c'est un peu différent dans les "Catégorie" de lien, puisque le code bloque dès le choix de la catégorie pour le lien. Il faut aussi changer à ce menu... [holalala]
    ça fait le deuxième qui me fait ça [Help]
    Pb réglé [Clin d oeil]

    Posté par Alérion, 03 août 2007 à 07:58
  • MERCI

    [Bouquet]Mille mercis Alérion
    tu m'as sauvé!
    [Salut]

    Posté par nuage de lait, 03 août 2007 à 10:12
  • DESESPOIR !!!

    J'ai moi aussi mis du scirpt dans ma categorie lien d'amis.
    J'ai essaye de suivre tes supers explications mais jusqu'àla sauvegarde du fichiers en HTML. Mais là quand je l'aouvre je n'ai pas du tout la liste de mes liens j'ai le "cadre" de ma page canalblog mais c'est tout (nouveau message, apparence...).
    Alors je me demande ce que j'ai pu loupé....
    Merci beaucoup de m'indiquer si tu as une idée, je ne voudrais pas perdre mon blog...

    Posté par Manue, 27 août 2007 à 08:20
  • compléments

    En fait j'ai mis ma ligne de script à 2 endroits : dans la ligne "ligne d'ami" ainsi que dans la catégorie. Je suppose que j'ai fait fort !!!

    Posté par Manue, 27 août 2007 à 08:31
  • :) oui bon

    c'est une nouvelle épidémie, on créait des catégories de lien pour y mettre le code, bon 3ème à ce que je vois...
    je te mail ce soir Manue[Clin d oeil], là de suite je ne peux t'aider[Sais pas]

    Posté par Alérion, 27 août 2007 à 10:49
  • Merci beaucoup.
    Et pas de problème, ce n'est pas vital !!![olléééé]
    En plus poru une fois qu'il fait beau (chez moi en tout cas), il vaut mieux profiter du soleil tant qu'il est là....
    Bonne journée.

    Posté par Manue, 27 août 2007 à 12:12
  • oki Manue, je t'ai mailée :)[Héééhooo]

    Posté par Alérion, 27 août 2007 à 18:54
  • j'suis pas la seule!!!

    je croyais que mon problème était unique et bien je vois que bcp de gens ont fait la même connerie que moi [mdr]
    mais bon c'est chiant j'y connait que dalle et tes explications ont beau l'air super j'ai pas envie de faire n'importe quoi!!!
    donc moi j'ai cliqué sur la superbe horloge d'une amie parce que je voulai la mienne; ils m'ont dis de copier ce lien sur mon blog chose que j'ai faite en le mettant soit dans une catégorie soit dans mes liens d'amis je sais plus (ho le boulet!!!!)[holalala]
    je retourne sur mon blog et piou plus rien il reste que mon titre plus de messages plus de liens plus rien les boules
    merci pour ton aide potentielle...

    Posté par amandine, 27 août 2007 à 21:19
  • Merci

    Un grand merci à Alerion pour son aide.[Bouquet]
    Tu as toute ma gratitude.[Youpiii]
    Bonne journée.

    Posté par Manue, 28 août 2007 à 07:14
  • de rien Manue :)
    Amandine, tu as mis ton code dans un lien d'ami, tu peux suivre totalement les explications données ici,
    tu ne risques que d'effacer la connerie, mais en tous cas rien de plus :)
    Aller go, je te regarde [copain]

    Posté par Alérion, 28 août 2007 à 19:12
  • s'il te plaît...

    aide moi!!! je ne retrouve pas les mêmes codes que toi...j'y connait vraiment rien du tout je sais pas ce que je dois effacer et je ne sais pas quel est le mauvais lien que j'ai installé!!! je suis paumé est ce que tu peux m'aider s'il te plaît au lieu de me regarder me planter[Bouée]je rame complet
    please please....[Ange]

    Posté par amandine, 28 août 2007 à 23:08
  • merci....

    ça y est je t'ai "invité" merci beaucoup de m'accorder un peu de ton temps...[Bouquet]

    Posté par amandine, 29 août 2007 à 10:52
  • merci

    merci à toi de nous aider... j'ai suivi tes explications... mais ça ne marche pas... je dois louper qq chose qq part... peux-tu m'aider en te connectant sur mon site... ça n'a pas un caractère d'urgence... on est vendredi... je ne peux me connecter quand semaine sur mon site...mais je peux te donner les infos... dis moi de quoi tu as besoin.. Merci si tu peux m'aider... amitiés

    Posté par iona, 31 août 2007 à 13:18
  • je peux, IONA, mais je n'ai pas l'adresse de ton site :)

    Posté par Alérion, 31 août 2007 à 18:54
  • Super tuto

    Hier soir j'ai du me prendre la tete pendant au moins 2 heures heuresement qu'on m'a donner ton blog car direct mon blog refonctionne [Youpiii][Youpiii]
    Par contre un truc vu que j'ai plante en mettant le code pour mon compteur visiteurs je le met ou ce code pour kil plante pas
    Merci beaucoup

    Bibounette

    Posté par Bibounette, 09 septembre 2007 à 08:43
  • [YoupYoup][Trinquer][Trinquer][Trinquer][Trinquer][Trinquer][Coder][Chaud][YoupYoup][Trinquer][Danser][Danser][Help][Danser][bon ok][Bouquet][Héééhooo][Héééhooo][mmm][mmm][houuuuu][Bouée]

    Posté par Bibounette, 09 septembre 2007 à 19:57
  • [Help][Ange][Attend]

    Posté par Bibounette, 09 septembre 2007 à 20:00
  • il faut passer en mode avancé, et tu le "fixe" dans une des colonnes [I](leftbar ou rightbar)[/I]

    Posté par Alérion, 10 septembre 2007 à 06:01
  • merci pour ton aide par contre les 2 derniers commentaire y'a mon speudo mais c'est pas moi qui les ai poster [Non]

    Posté par Bibounette, 10 septembre 2007 à 16:03
  • merci pour tte cette aide

    vraiment aide precieuse,moi mon pb je voulais introduire un compteur sur mon blog, et la surprise mes liens d amis ont disparus, et j ai suivi a la lettre ce que tu as dis mais sans succes,apres suppression et sauvgarde , la fenetre ne s ouvre pas comme prevu,ya toujours dans les liens compteur et a cote ecrit en bleu : claire=">.....
    je suis perdu et je veux retrouver mes liens, merci a toi
    gros bisou

    Posté par benisou, 22 septembre 2007 à 00:09
  • J'ai dû faire encore plus fort!

    Salut Alérion,
    je sais maintenant que je ne suis pas la seule à faire des "bétises" et ça me rassure. selon mon mari, j'ai bousillé notre blog. Il a peut-être raison, mais je voudrais me donner une chance: TOI!
    En résumé, j'ai collé un code HTML (à partir de clocklink.com) dans "liens d'amis" partout où je pouvais (nom, adresse internet & rss, catégorie). J'ai fait fort, n'est-ce pas? Bref, je n'ai plus les albums et les catégories dans la colonne droite. D'abord quand je clique droit pour avoir la source, je n'ai pas un bloc note mais une page "source of:http://..." et je ne peux pas modifier le texte. En plus quand je suis sur la page "liens d'amis", je n'ai plus "ou ajouter une nouvelle catégorie pour ce lien" et le bouton "ajoute". C'est grave Dr?
    En tout cas si tu peux m'aider, ça sera hyper chouette (je n'aurai plus un mari qui me fait la tête depuis cet aprèm!). A bientôt j'espère.

    Posté par novine, 30 septembre 2007 à 05:44
  • [mmm]Comment on peut insister comme ça? si ça n efonctionne pas dès le premier, pourquoi en mettre partout?, bon cas extrème... oui tu es sans doute sous firefoxe? je pense que dans ce cas il faut sauvegarder d'abord pour pouvoir faire les modifs après... j'ai pas testé, faudra bien que je m'y mette aussi tiens.
    bon je te mail :)[Coder]

    Posté par Alérion, 30 septembre 2007 à 08:27
  • Coucou Alérion,
    et oui, plus têtue que ça n'existe pas! la preuve!!! Je suis sous firefox. je serai très contente d'avoir des bonnes nouvelles venant de toi, sinon je devrais faire ma valise et rentrer en France (lol).
    Merci encore.
    @+.

    Posté par novine, 30 septembre 2007 à 17:42
  • Merci

    Mille mercis à toi, Alérion! ça marche comme avant.
    @+

    javascript:;
    Bravo

    Posté par novine, 02 octobre 2007 à 21:21
  • Il faut vraiment que je prenne qq cours d'informatique :)

    Posté par novine, 02 octobre 2007 à 21:24
1  2  3    Dernier »

Poster un commentaire