Des trucs et des astuces

Alors amusons -nous ;)

27 avril 2007

J'ai mis du code HTML dans "Liens d'amis"

...et maintenant, ça n'affiche plus rien....

Au début, on a un code à insérer dans son blog, pour un compteur, une horloge, un post-it et/ou un éphéméride...

Et bien, sûr , comme on le veut sur une colonne pourquoi pas les "liens d'amis" bonne idée ça!!!!


oui oui oui, et zou c'est parti sauf qu'une fois qu'on a appuyé, le résultat n'est pas celui escompté, plus rien, un vide...

même plus les autres liens,

Rhaaaaaaa $£¤*ù%%, Diaule!!! mais qu'ai-je fait!!!!! (aparté pour ceux qui l'ont déjà fait dans les catégories - zêtes tétus vous....)

Bon.... on fait comment maintenant? Il faut corriger, supprimer la source du bug. (j'ai comme l'impression de me répéter moi).


Dans un premier temps il faut cliquer-droit dans cette fenêtre de "Gestion des liens" et sélectionner "Afficher la source"

Le code Html de la page va se retrouver dans le bloc-notes.

(Nota: Avec un navigateur FF, il faut tout sélectionner, le copier et recoller le code dans le bloc note pour pouvoir modifier et sauvegarder correctemement)
(attention très important, restez connecté sur votre interface canalblog pendant toutes les opérations)

et dans ce fichier source on va juste "bidouiller" un peu de code, en prenant toutes les précautions d'usage, d'accord?

déjà juste pour comprendre, il faut savoir que les liens et le dernier ajouté font partie du code html de la page, mais, comme ce dernier lien est du code incomplet, l'explorateur ne peut l'interpréter, et n'affiche plus rien après.

donc nous nous trouvons avec un fichier (ici my[2]), il faut repérer les lignes où sont inscrits les liens... vous reconnaîtrez facilement le votre.


on repère facilement les <a href="....>là se situe en général le nom du lien mais dans lequel figure maintenant le <script...> </td>
06lelien
on sélectionne tout ce qui est entre les balise <a href="..."> </a></td> et on y met "A supprimer" (bon c'est simplement pour bien définir celui qui est à effacer)

Ensuite on va encore modifier autre chose, en dessous de ce titre, il y a une ligne marquée :"<a href="/cf/my/action/FriendLinkController.cfc?bid...." cette ligne sert à supprimer le lien (3 ème ligne en dessous de celle qu'on a déjà modifiée)
il faut rajouter l'adresse de Canalblog juste avant "/cf/my/action...."

Voilà nous y sommes presque, ce fichier on va le sauvegarder sur notre disque, avec l'extension ".html": important, car ça va nous permettre de le lancer avec l'explorateur. (Démarrer - mes document - my[2].html)

Donc on le lance, la page va s'afficher il n'y aura pas de décoration, ni de mise en page, mais peu importe, le tableau avec les liens apparaît , dont le "a supprimer" (faute d'orthographe incluse)

et on va appuyer sur le carré à droite de "Editer" qui permet de l'effacer (un carré car pas d'image chargée), avec notre modif, la seule chose que vous pourrez effectuer est la suppression, tout le reste ne fonctionnera pas. donc go sur le bouton à droite de Editer

si tout va bien, vous devriez revenir sur un tableau avec toute la liste de vos liens

(et bon je le répète: ce n'est pas une raison, non plus, pour y remettre du code, ok?)


Commentaires

    wahou!!!

    Un grand grand merci!!! sans ton explication j'ai cru avoir tout perdu!!!!

    un grand ouf de soulagement

    Posté par jenniloulou, 19 novembre 2010 à 01:51
  • Bonjour,
    J'ai un gros soucis suite à une mauvaise manip en voulant montrer à ma fille comment mettre de la neige sur mon blog.
    Les liens d'amis ont disparu.
    j'ai voulu les remettre mais cela décalait complètement mon blog.
    De plus la possibilité décrire le mot lien est impossible, et ajouter cliquable a complètement disparu. j'ai beau lire votre aide, je n'y comprends rien du tout, j'ai peur de refaire une fausse manip. merci de m'aider
    Sylvie

    Posté par sylvie rêveries, 04 décembre 2010 à 17:12
  • Pas de "à supprimer" dans la page

    Bonjour, j'ai suivi votre tuto .
    Jusqu'au moment de charger mon 'my[2]html', out va bien mais
    une fois, le fichier html lancé, je n'ai pas du tout la même page que vous.
    De plus, nulle part sur cette(ma)apge se trouve écrit à supprimer ( que j'ai orthographié de la sorte à supprimer, je pense au bon endroit ici:
    <td width="200">  <a href=":url:#ffff66" id="pluiedetoiles">à supprimer</a></td>

    voilà.
    La page sur laquelle je bloque est en fait, je crois, la même page ( sans les décorations et mise en page) sur laquelle je bloque lorsque je suis sur mon administration dans "liens d'amis".

    Merci d'avance si vous avez une idée sur le problème.

    Posté par Lesyeuxducyclone, 01 février 2011 à 15:21
  • Je me sens moins seule...

    ...et je tenterai de réparer demain grâce à ton super tuto; j'espère pour voir te vénérer :-D J'ai au moins compris qu'il y avait encore de l'espoir, maintenant, je me pose des questions, je suis passée bien trop vite en mode avancé :-( merci [Aimer Ordi]

    Posté par Rose & Cook, 13 février 2011 à 01:30
  • Au secours !

    Comme beaucoup j'ai voulu faire maligne en insérant le code d'un compteur, mais je ne le suis pas tant que ça puisque je n'arrive pas à retirer le foutu script qui m'a "bouffé" une partie de mes catégories et leurs contenus sans que je puisse toucher à quoi que ce soit (j'ai mis 3 ans à faire une liste de tutos...) Très malchanceuse cette année, j'ose te demander de l'aide je suis même prête à t'envoyer mes identifiants pour que tu puisse voir car vraiment, je n'y comprends rien. Tu as fait un tuto clair, mais je n'arrive à rien modifier, ni en passant par firefox ni par explorer... Seras-tu ma dernière chance ? Voici le code que je pense avoir repéré en faisant "afficher la source": <td width="200">  <a href=":url:<!-- Debut du code Domino Counter --> <script type="text/javascript">var dominocounter_a = "aurorebbb";</script> <script ">compteur</a></td>

    Merci d'avance de tout coeur et pardon de te déranger en WE ! [heuu hum]

    Posté par Mirandoline, 06 août 2011 à 13:20
  • C'est encore moi !

    Je me suis acharnée et je pense que je n'ai plus besoin de te déranger ! ouf !!! Je t'explique comment j'y suis parvenue: j'ai tenté le tout pour le tout et j'ai supprimé directement la catégorie dans laquelle j'avais inséré le code ! J'ai perdu cette catégorie certes, mais toutes les autres sont réapparues, les plus importantes ! Donc les dégâts sont bien minimes, et je n'ai qu'à refaire la catégorie disparue qui n'était pas la plus travaillée !! Chouette ! Merci pour le tuto qui m'a appris bien des choses, c'est tellement gentil pour toutes les grosses nouilles que nous sommes parfois quand on bidouille sans savoir où ça va nous mener !!![:D]
    Grosses bises !

    Posté par Mirandoline, 06 août 2011 à 15:14
  • problème bloc liens d'amis

    bonjour ,
    en voulant mettre une pluie sur mon blog
    j'ai tout effacé le bloc " liens d'amis "
    c'est fichu ???
    je suis bloquée avec les qq seules qui étaient en liste sur la colonne du blog
    je me demande si c'est réparable ,
    MERCI !de me répondre : je suis novice & nulle en informatique

    Posté par kris, 26 septembre 2011 à 01:26
  • au secours ....

    je suis comme les autres ... grosse gaffe !! j'étais loin de me douter de ce qu'allait entrainer le fait de vouloir mettre une horloge ....
    je suis dépitée ....
    j'ai essayé de suivre ton tuto mais je ne trouve pas le code html dans le bloc note ..
    est ce que tu pourrais m'aider ??? c'est presque une question de vie ou de mort ... j'y tiens tellement à mon blog ...
    voici mon mail si tu peux m'aider :
    sandrine.ribeirix@orange.fr
    merci infiniment par avance
    bonne soirée

    Posté par sandrine, 08 avril 2012 à 18:52
  • au secours

    Bonjour,
    Cela ne se présente pas comme dans les explications, je ne trouve pas ce qu'il faut supprimer, pour retirer le lien. SVP je souhaite retirer le code du lien traducteur en ligne. peut être les choses ont chnagé depuis 2007. Voila ce qui s'affiche :



    Liens






    OU ajoutez une nouvelle catégorie pour ce lien :












    Catégorie & Site
    Lien RSS
    Modifier
    Supprimer
    <script type="text/javascript" src="http://www.traducteurenligneSupprimer cette catégorie

      Bienvenue

    Editer


    LiensSupprimer cette catégorie

    Posté par Alpha, 24 septembre 2013 à 19:37
  • t'aider ?!

    Bonjour Alpha,
    je ne sais pas trop sur Alérion répond, en ce moment, pour les comm sur ce blog.
    Je peux essayer de t'aider ( il m'est arrivé la mm chose que toi avec un canalblog mais c'était il y adeux ou trois ans! La manoeuvre donnée par Alérion avait bien fonctionné ).
    A quel niveau de la procédure, ça bloque chez toi ?
    ( ( ya eu effectivement beaucoup de changements, mise à jour sur la canalblog plateforme et il ne peut que , donc, les 'pages web' ne se présentent plus exactement comme l'indiquait ce tuto.))

    Posté par lucy, 25 septembre 2013 à 11:03
  • Bonjour Lucy, tout d'abord merci de m'avoir répondu.

    - J'ai récupéré la page .html depuis la page" liens externe du blog".
    - Je l'ai ensuite ouverte dans le bloc notes, puis modifié,
    - Mais ensuite quand je la lance, j'arrive à l'ensemble des menus, : "nouveau message", "apparence", "contenu", etc, le "lien d'amis" en faisant partie.
    Et quand où que ce soit, cela me marque : "cette page web est introuvable"..

    Le lien que je cherche à éliminer se situe dans les "liens d'amis" et il s'appelle : http://www.traducteurenligne.net

    Mais si tout enlever est un manip plus simple, je n'aurais plus qu'à rentrer à nouveau les liens, je ne sais pas.. Je ne connais pas du tout le language .html.

    Et si je te donne le mot de passe pour rentrer sur mon blog pour que tu jettes un coup d'oeil ? . Mais dans ce cas il faudrait que tu m'envoies une adresse email à philomane@gmail.com

    Posté par Alpha, 25 septembre 2013 à 19:27
  • Bizarre !

    Bizarre que lorsque tu lances ta page html modifiée en local, il apparaisse une page comme tu la décris et non une page comme la fenêtre pour enregistrer des liens amis (mais sans aucun style).
    C'est pas que je ne veille pas intervenir sur ton blog, mais , j'y suis allée et je ne vois pas le désordre que j'avais lorsque j'avais introduit un code trop long via les " liens amis" (ça m'avait planté tout le blog, je n'avais plus du tout accès à l'interface de gestion du blog.) Je ne constate pas la mm chose chez toi et donc je me demande si ce tuto de réparation convient bien à ton problème..
    Bon... je t'envoie un mail en privé , plus tard dans la soirée pour savoir exactement comment se manifeste ton problème

    Posté par lucy, 25 septembre 2013 à 20:15
  • Lucy,

    En fait j'avais le désordre total, mais j'ai partiellement contourné le problème en allant dans "apparence"/ "blocs" / "organisation des blocs" et j'ai retiré le bloc des liens de la liste.
    Mais si je le remets c'est pas beau à voir. Et un blog sans liens, c'est le blog d'un solitaire, qui ne communique pas avec les autres, qui ne fait aucune pub pour ses amis, alors qu'ils en font pour moi...

    Posté par Alpha, 25 septembre 2013 à 20:53
  • Rapide, j'ai pas encore mangé !
    Dans ton interface d'administration/tableau de bord, as-tu encore accès à onglet liens d'amis puis gestion des liens ?

    Posté par lucy, 25 septembre 2013 à 21:01
  • Oui je parviens jusqu'à "liens d'amis" puis "liens" ou "renommer une catégorie de liens". Le problème c'est au niveau du curseur "sélectionner une catégorie", que rien ne m'est proposé que ce soit dans liens d'amis ou renommer une catégorie de liens.

    Posté par Alpha, 25 septembre 2013 à 21:13
  • C'est peut-être normal que rien ne te soit proposé dans "sélectionner une catégorie".
    Avais-tu fait des catégories dans tes liens amis ?
    Je te mets une photo
    http://p0.storage.canalblog.com/03/66/1068070/90110120_o.jpg

    Est ce que vers le bas de ta fenêtre "gestion des liens" tu as une ligne qui commence par